<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>How to Restrict SSH Access to Certain Users in Linux</title>

		<!-- All in One SEO 4.1.2.1 -->
		<meta name="description" content="In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server."/>
		<meta name="google-site-verification" content="zIbNGYDwK0jyVAaRBI_irNyL78giGmx9AHjRJSwNWCo" />
		<meta name="keywords" content="allow ssh access to user,limit ssh access to specific users,enable ssh access to user,ssh allow users list,ssh tips" />
		<link rel="canonical" href="https://www.linuxshelltips.com/restrict-ssh-access-user/" />
		<meta property="og:site_name" content="Linux Shell Tips - The Best Linux Command Line Web Portal | Linux Tips, Tricks, Hacks, Tutorials and Ideas in Blog" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="How to Restrict SSH Access to Certain Users in Linux" />
		<meta property="og:description" content="In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server." />
		<meta property="og:url" content="https://www.linuxshelltips.com/restrict-ssh-access-user/" />
		<meta property="og:image" content="https://www.linuxshelltips.com/wp-content/uploads/2021/01/linuxshelltips.png" />
		<meta property="og:image:secure_url" content="https://www.linuxshelltips.com/wp-content/uploads/2021/01/linuxshelltips.png" />
		<meta property="og:image:width" content="300" />
		<meta property="og:image:height" content="300" />
		<meta property="article:published_time" content="2021-07-07T09:25:22Z" />
		<meta property="article:modified_time" content="2021-07-07T09:25:22Z" />
		<meta property="article:publisher" content="https://facebook.com/linuxshelltips" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@linuxshelltips" />
		<meta name="twitter:domain" content="www.linuxshelltips.com" />
		<meta name="twitter:title" content="How to Restrict SSH Access to Certain Users in Linux" />
		<meta name="twitter:description" content="In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server." />
		<meta name="twitter:image" content="https://www.linuxshelltips.com/wp-content/uploads/2021/01/linuxshelltips.png" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.linuxshelltips.com\/#website","url":"https:\/\/www.linuxshelltips.com\/","name":"Linux Shell Tips - The Best Linux Command Line Web Portal","description":"Linux Tips, Tricks, Hacks, Tutorials and Ideas in Blog","publisher":{"@id":"https:\/\/www.linuxshelltips.com\/#person"}},{"@type":"Person","@id":"https:\/\/www.linuxshelltips.com\/#person","name":"Linux Shell Tips","image":{"@type":"ImageObject","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#personImage","url":"https:\/\/secure.gravatar.com\/avatar\/3119bc5c1b33d383b163ca48672cb216?s=96&d=mm&r=g","width":"96","height":"96","caption":"Linux Shell Tips"},"sameAs":["https:\/\/facebook.com\/linuxshelltips","https:\/\/twitter.com\/linuxshelltips","https:\/\/instagram.com\/linuxshelltips","https:\/\/www.linkedin.com\/company\/linux-shell-tips","https:\/\/linuxshelltips.tumblr.com"]},{"@type":"BreadcrumbList","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.linuxshelltips.com\/#listItem","position":"1","item":{"@type":"WebPage","@id":"https:\/\/www.linuxshelltips.com\/","name":"Home","description":"Linux Command Line Tips, Tricks, Hacks, Tutorials, and Ideas in Blog","url":"https:\/\/www.linuxshelltips.com\/"},"nextItem":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#listItem","position":"2","item":{"@type":"WebPage","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/","name":"How to Restrict SSH Access to Certain Users in Linux","description":"In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server.","url":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/"},"previousItem":"https:\/\/www.linuxshelltips.com\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.linuxshelltips.com\/author\/ravisaive\/#author","url":"https:\/\/www.linuxshelltips.com\/author\/ravisaive\/","name":"Ravi Saive","image":{"@type":"ImageObject","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/7badddbc53297b2e8ed7011cf45df0c0?s=96&d=mm&r=g","width":"96","height":"96","caption":"Ravi Saive"},"sameAs":["https:\/\/facebook.com\/linuxshelltips","https:\/\/twitter.com\/linuxshelltips","https:\/\/instagram.com\/linuxshelltips","https:\/\/www.linkedin.com\/company\/linux-shell-tips","https:\/\/linuxshelltips.tumblr.com"]},{"@type":"WebPage","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#webpage","url":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/","name":"How to Restrict SSH Access to Certain Users in Linux","description":"In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server.","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/www.linuxshelltips.com\/#website"},"breadcrumb":{"@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#breadcrumblist"},"author":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#author","creator":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#author","datePublished":"2021-07-07T09:25:22+05:30","dateModified":"2021-07-07T09:25:22+05:30"},{"@type":"Article","@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#article","name":"How to Restrict SSH Access to Certain Users in Linux","description":"In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server.","headline":"How to Restrict SSH Access to Certain Users in Linux","author":{"@id":"https:\/\/www.linuxshelltips.com\/author\/ravisaive\/#author"},"publisher":{"@id":"https:\/\/www.linuxshelltips.com\/#person"},"datePublished":"2021-07-07T09:25:22+05:30","dateModified":"2021-07-07T09:25:22+05:30","articleSection":"Security, SSH, SSH Tips","mainEntityOfPage":{"@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#webpage"},"isPartOf":{"@id":"https:\/\/www.linuxshelltips.com\/restrict-ssh-access-user\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/www.linuxshelltips.com\/#articleImage","url":"https:\/\/www.linuxshelltips.com\/wp-content\/uploads\/2021\/07\/Limit-SSH-Access-to-user-Accounts.png","width":"575","height":"264","caption":"Limit SSH Access to User Accounts"}}]}
		</script>
		<!-- All in One SEO -->

<link rel='dns-prefetch' href='//www.linuxshelltips.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Linux Shell Tips - The Best Linux Command Line Web Portal &raquo; Feed" href="https://www.linuxshelltips.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Shell Tips - The Best Linux Command Line Web Portal &raquo; Comments Feed" href="https://www.linuxshelltips.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Shell Tips - The Best Linux Command Line Web Portal &raquo; How to Restrict SSH Access to Certain Users in Linux Comments Feed" href="https://www.linuxshelltips.com/restrict-ssh-access-user/feed/" />
<link rel='stylesheet' id='wp-show-posts-css'  href='https://www.linuxshelltips.com/wp-content/plugins/wp-show-posts/css/wp-show-posts-min.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://www.linuxshelltips.com/wp-content/themes/linuxshelltips/css/all.min.css?ver=2.4.2' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-child-css'  href='https://www.linuxshelltips.com/wp-content/themes/linuxshelltips_child/style.css?ver=1610775774' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css'  href='https://www.linuxshelltips.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=2.0.2' type='text/css' media='all' />
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#1e3545;background-repeat:repeat-x;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle,.secondary-menu-bar-items .menu-bar-item > a{color:#ffffff;font-weight:900;font-size:15px;padding-left:19px;padding-right:19px;line-height:60px;}.secondary-navigation .secondary-menu-bar-items{color:#ffffff;font-size:15px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:20px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:14px;padding-left:19px;padding-right:19px;}.secondary-navigation .menu-item-has-children .dropdown-menu-toggle{padding-right:19px;}.secondary-navigation .main-nav ul li:hover > a,.secondary-navigation .main-nav ul li:focus > a,.secondary-navigation .main-nav ul li.sfHover > a,.secondary-menu-bar-items .menu-bar-item:hover > a{color:#ffffff;background-color:rgba(255,255,255,0);}.secondary-navigation .main-nav ul ul li:hover > a,.secondary-navigation .main-nav ul ul li:focus > a,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:rgba(84,84,84,0);}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}@media (max-width:768px) {.secondary-menu-bar-items .menu-bar-item:hover > a{background: none;color: #ffffff;}}
</style>
<link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='https://www.linuxshelltips.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style-mobile.min.css?ver=2.0.2' type='text/css' media='all' />
<meta name="viewport" content="width=device-width, initial-scale=1"><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-188680645-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-188680645-1');
</script><link rel="icon" href="https://www.linuxshelltips.com/wp-content/uploads/2021/01/cropped-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxshelltips.com/wp-content/uploads/2021/01/cropped-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.linuxshelltips.com/wp-content/uploads/2021/01/cropped-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxshelltips.com/wp-content/uploads/2021/01/cropped-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.wp-show-posts .wp-show-posts-entry-title {font-size:15px;}
.wp-show-posts-entry-title a {font-weight:normal}

.wpsp-related-posts h2 {
    color: #004c16;
    font-weight: 800;
	margin-bottom: 25px;
}
.relatedread {background-color: #f3f8fb;border-left: 4px solid #0c9103;display: block;padding: 10px;margin-bottom: 25px;}
.relatedread a {text-decoration: underline;}		</style>
		</head>

<body class="post-template-default single single-post postid-1943 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-center right-sidebar nav-below-header fluid-header separate-containers active-footer-widgets-3 header-aligned-center dropdown-hover" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>			<nav id="secondary-navigation" class="secondary-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope">
				<div class="inside-navigation grid-container grid-parent">
										<button class="menu-toggle secondary-menu-toggle">
						<span class="mobile-menu">Menu</span>					</button>
					<div class="main-nav"><ul id="menu-header_menu" class=" secondary-menu sf-menu"><li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://www.linuxshelltips.com/">Home</a></li>
<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://www.linuxshelltips.com/about/">About Us</a></li>
<li id="menu-item-130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130"><a href="https://www.linuxshelltips.com/contact/">Contact Us</a></li>
<li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-128"><a href="https://www.linuxshelltips.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-359" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-359"><a href="https://www.linuxshelltips.com/submit-linux-tips-and-tricks/">Submit Linux Tip</a></li>
<li id="menu-item-1697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1697"><a href="https://www.linuxshelltips.com/category/linux-download/">Linux Download<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-1715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1715"><a href="https://www.linuxshelltips.com/download-rhel-8/">RHEL Linux</a></li>
	<li id="menu-item-1745" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1745"><a href="https://www.linuxshelltips.com/rocky-linux-download/">Rocky Linux</a></li>
	<li id="menu-item-1746" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1746"><a href="https://www.linuxshelltips.com/almalinux-download/">AlmaLinux</a></li>
	<li id="menu-item-1716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1716"><a href="https://www.linuxshelltips.com/download-kali-linux/">Kali Linux</a></li>
	<li id="menu-item-1717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1717"><a href="https://www.linuxshelltips.com/manjaro-linux-download/">Manjaro Linux</a></li>
</ul>
</li>
<li id="menu-item-1712" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1712"><a href="https://www.linuxshelltips.com/category/virtualization/">Linux Virtualization<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-1714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1714"><a href="https://www.linuxshelltips.com/category/virtualbox/">VirtualBox</a></li>
	<li id="menu-item-1713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1713"><a href="https://www.linuxshelltips.com/category/vagrant/">Vagrant</a></li>
</ul>
</li>
</ul></div>				</div><!-- .inside-navigation -->
			</nav><!-- #secondary-navigation -->
					<header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
			<div class="inside-header grid-container grid-parent">
				<div class="site-logo">
				<a href="https://www.linuxshelltips.com/" title="Linux Shell Tips &#8211; The Best Linux Command Line Web Portal" rel="home">
					<img  class="header-image" alt="Linux Shell Tips &#8211; The Best Linux Command Line Web Portal" src="https://www.linuxshelltips.com/wp-content/uploads/2020/08/logo.png" title="Linux Shell Tips &#8211; The Best Linux Command Line Web Portal" />
				</a>
			</div>			</div><!-- .inside-header -->
		</header><!-- #masthead -->
		
	<div id="page" class="hfeed site grid-container container grid-parent">
				<div id="content" class="site-content">
			
	<div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75">
		<main id="main" class="site-main">
			
<article id="post-1943" class="post-1943 post type-post status-publish format-standard hentry category-security category-ssh tag-ssh-tips" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
		
		<header class="entry-header">
			<h1 class="entry-title" itemprop="headline">How to Restrict SSH Access to Certain Users in Linux</h1>			<div class="entry-meta">
				 <span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author"><a href="https://www.linuxshelltips.com/author/ravisaive/" title="View all posts by Ravi Saive" rel="author"><span class="author-name" itemprop="name">Ravi Saive</span></a></span></span><span class="posted-on"><time class="entry-date published" datetime="2021-07-07T14:55:22+05:30" itemprop="datePublished">July 7, 2021</time> </span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.linuxshelltips.com/category/security/" rel="category tag">Security</a>, <a href="https://www.linuxshelltips.com/category/ssh/" rel="category tag">SSH</a></span> <span class="comments-link"><a href="https://www.linuxshelltips.com/restrict-ssh-access-user/#respond">Leave a comment</a></span> 			</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

		
		<div class="entry-content" itemprop="text">
			<p>OpenSSH (Secure Shell) is a standard connectivity program for logging into a remote machine using the SSH protocol for executing commands on the remote machine. It encrypts all network traffic between client and server to eradicate eavesdropping, connection hijacking, and other attacks.</p>
<p><strong>[ You might also like: <a title="How to Disable SSH Login to Specific User in Linux" href="https://www.linuxshelltips.com/disable-ssh-user-login/" target="_blank" rel="noopener">How to Disable SSH Login to Specific User in Linux</a> ]</strong></p>
<p>In addition, OpenSSH offers a large suite of secure tunneling capabilities, various authentication methods, and sophisticated configuration options. One such security feature is limiting or restricting the SSH access to certain users using the <strong>AllowUsers</strong> keyword that accepts SSH connections from the list of specified local accounts in the SSH configuration file.</p>
<p>In this article, you will learn how to restrict or whitelist certain user accounts to access SSH incoming connections on your Linux server.</p>
<h3>Restricting SSH Access to User Accounts</h3>
<p>To limit ssh access for a user called &#8216;<strong>linuxshelltips</strong>&#8216;, use the sshd ’s <code>AllowUsers</code> keyword in <strong>/etc/ssh/sshd_config</strong> file.</p>
<pre>$ sudo vi /etc/ssh/sshd_config
OR
$ sudo nano /etc/ssh/sshd_config
</pre>
<p>To allow SSH connections from user &#8216;<strong>linuxshelltips</strong>&#8216; account, but no other accounts.</p>
<pre>AllowUsers linuxshelltips
</pre>
<p>You can add multiple user accounts separated by spaces, for example:</p>
<pre>AllowUsers user1 user2 user3
</pre>
<p>You can confirm this by running the following command.</p>
<pre>$ cat /etc/ssh/sshd_config | grep -i allowusers
</pre>
<figure id="attachment_1949" aria-describedby="caption-attachment-1949" style="width: 565px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-1949" src="https://www.linuxshelltips.com/wp-content/uploads/2021/07/Limit-SSH-Access-to-user-Accounts.png" alt="Limit SSH Access to User Accounts" width="575" height="264" /><figcaption id="caption-attachment-1949" class="wp-caption-text">Limit SSH Access to User Accounts</figcaption></figure>
<p>After modifying <strong>sshd_config</strong>, make sure to restart <strong>sshd</strong> to incorporate your changes.</p>
<pre>$ sudo systemctl restart sshd
</pre>
<h3>Verify SSH Access to User Accounts</h3>
<p>Now try to connect to a Linux system using a different user account called &#8216;<strong>ravi</strong>&#8216; who is not mentioned in the SSH allowed list so he cannot receive SSH connections.</p>
<pre>$ ssh ravi@192.168.0.175

ravi@192.168.0.141's password: 
<strong>Permission denied, please try again.</strong>
</pre>
<p>Furthermore, you can also confirm this by checking the ssh logs at <strong>/var/log/secure</strong> file.</p>
<pre>$ cat /var/log/secure | grep -i allowusers
</pre>
<figure id="attachment_1954" aria-describedby="caption-attachment-1954" style="width: 1132px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-1954" src="https://www.linuxshelltips.com/wp-content/uploads/2021/07/Check-SSH-Logs.png" alt="Check SSH Logs" width="1142" height="154" srcset="https://www.linuxshelltips.com/wp-content/uploads/2021/07/Check-SSH-Logs.png 1142w, https://www.linuxshelltips.com/wp-content/uploads/2021/07/Check-SSH-Logs-768x104.png 768w" sizes="(max-width: 1142px) 100vw, 1142px" /><figcaption id="caption-attachment-1954" class="wp-caption-text">Check SSH Logs</figcaption></figure>
<p>Now try to log in with a user <code>'linuxshelltips'</code> who is allowed to connect into the system because it’s in the allowed user&#8217;s list.</p>
<pre>$ ssh linuxsheltips@192.168.0.175
$ su -
$ cat /var/log/secure | grep -i linuxshelltips
</pre>
<figure id="attachment_1955" aria-describedby="caption-attachment-1955" style="width: 1336px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-1955" src="https://www.linuxshelltips.com/wp-content/uploads/2021/07/Confirm-SSH-User-Login.png" alt="Confirm SSH User Login" width="1346" height="564" srcset="https://www.linuxshelltips.com/wp-content/uploads/2021/07/Confirm-SSH-User-Login.png 1346w, https://www.linuxshelltips.com/wp-content/uploads/2021/07/Confirm-SSH-User-Login-768x322.png 768w" sizes="(max-width: 1346px) 100vw, 1346px" /><figcaption id="caption-attachment-1955" class="wp-caption-text">Confirm SSH User Login</figcaption></figure>
		</div><!-- .entry-content -->

					<footer class="entry-meta">
				<span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://www.linuxshelltips.com/tag/ssh-tips/" rel="tag">SSH Tips</a></span> 		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.linuxshelltips.com/sync-vscode-settings/" rel="prev">How to Sync VSCode Settings Across Any Machines</a></span></div>		</nav><!-- #nav-below -->
					</footer><!-- .entry-meta -->
		<div class="wpsp-related-posts  grid-container">
	<h2>RECOMMENDED ARTICLES</h2>
<style>.wp-show-posts-columns#wpsp-601 {margin-left: -1em; }.wp-show-posts-columns#wpsp-601 .wp-show-posts-inner {margin: 0 0 1em 1em; }</style><section id="wpsp-601" class=" wp-show-posts-columns wp-show-posts" style=""><article class=" wp-show-posts-single post-1834 post type-post status-publish format-standard hentry category-security category-ssh category-ubuntu tag-ssh-tips tag-ubuntu-tips wpsp-col-6" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/install-ssh-in-ubuntu/" rel="bookmark">How to Install SSH Server in Ubuntu 20.04</a></p>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-1099 post type-post status-publish format-standard hentry category-centos category-debian category-security category-ssh category-ubuntu tag-ssh-tips wpsp-col-6" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/create-ssh-key-passphrase/" rel="bookmark">How to Create an SSH Key Passphrase in Linux</a></p>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --></article><div class="wpsp-clear"></div></section><!-- .wp-show-posts --></div>	</div><!-- .inside-article -->
</article><!-- #post-## -->

					<div class="comments-area">
						<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Got something to say? Join the discussion. <small><a rel="nofollow" id="cancel-comment-reply-link" href="/restrict-ssh-access-user/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.linuxshelltips.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1943' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="57e6854b18" /></p><input type="hidden" id="ak_js" name="ak_js" value="215"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
					</div>

							</main><!-- #main -->
	</div><!-- #primary -->

	<div id="right-sidebar" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="search-2" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.linuxshelltips.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search">
</form>
</aside><aside id="custom_html-3" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<div class="socialprofiles">
<h2 style="font-weight:800;color:#004c16;font-size:20px;">Join Linux Shell Tips</h2>
<a href="https://www.facebook.com/linuxshelltips" target="_blank" rel="nofollow noopener noreferrer" title="Join LinuxShellTips on Facebook"><img alt="Join LinuxShellTips" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/facebook.png"></a>
<a href="https://twitter.com/linuxshelltips" target="_blank" rel="nofollow noopener noreferrer" title="Follow LinuxShellTips on Twitter"><img alt="Follow LinuxShellTips on Twitter" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/twitter.png"></a>
<a href="https://www.reddit.com/user/linuxshelltips" target="_blank" rel="nofollow noopener noreferrer" title="Follow LinuxShellTips on Reddit"><img alt="Follow LinuxShellTips on Reddit" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/reddit.png"></a>
<a href="https://www.linkedin.com/company/linux-shell-tips" target="_blank" rel="nofollow noopener noreferrer" title="Follow LinuxShellTips on Linkedin"><img alt="Follow LinuxShellTips on Linkedin" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/linkedin.png"></a>
<a href="https://www.instagram.com/linuxshelltips/" target="_blank" rel="nofollow noopener noreferrer" title="Follow LinuxShellTips on Instagram"><img alt="Follow LinuxShellTips on Instagram" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/instagram.png"></a>
<a href="https://feedly.com/i/subscription/feed/https://www.linuxshelltips.com/feed/" target="_blank" rel="nofollow noopener noreferrer" title="Follow LinuxShellTips via RSS Feed"><img alt="Follow LinuxShellTips via RSS Feed" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/rss.png"></a>
<a href="https://t.me/linuxshelltips" target="_blank" rel="nofollow noopener noreferrer" title="Join LinuxShellTips Telegram Channel"><img alt="Join LinuxShellTips Telegram Channel" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/telegram.png"></a>
<a href="https://linuxshelltips.tumblr.com/" target="_blank" rel="nofollow noopener noreferrer" title="Follow LinuxShellTips on Tumblr"><img alt="Follow LinuxShellTips on Tumblr" src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/tumblr.png"></a>
</div></center></div></aside><aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><p align="center"><a rel="nofollow noopener" href="https://follow.it/linux-shell-tips?action=followPub" target="_blank"><img src="https://www.linuxshelltips.com/wp-content/uploads/2021/06/Follow-LinuxShellTips.png" alt="Buy Me A Coffee"></a></p></div></aside><aside id="custom_html-2" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><p align="center"><a rel="nofollow noopener" href="https://www.buymeacoffee.com/linuxshelltips" target="_blank"><img src="https://www.linuxshelltips.com/wp-content/uploads/2021/01/supportus.png" alt="Buy Me A Coffee" style="height: 60px !important;width: 300px !important;" ></a></p></div></aside><aside id="custom_html-4" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><div style="border: 5px solid green;padding: 10px;    text-decoration: underline;text-align:center;"><a title="Getting Started with VirtualBox" target="_blank" href="https://www.linuxshelltips.com/virtualbox/" rel="noopener">VirtualBox Getting Started Guide</a></div></div></aside><aside id="wpsp_widget-2" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Linux Command Line Tips</h2><style>.wp-show-posts-columns#wpsp-488 {margin-left: -2em; }.wp-show-posts-columns#wpsp-488 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-488" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-560 post type-post status-publish format-standard hentry category-linux-commands category-shell-tips tag-linux-tips-tricks tag-shell-scripting-tips" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/store-linux-command-in-variable/" rel="bookmark">How to Store a Linux Command as a Variable in Shell Script</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-573 post type-post status-publish format-standard hentry category-linux-commands category-shell-tips tag-linux-tips-tricks tag-ulimit-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/change-open-file-limit-in-linux/" rel="bookmark">How to Change Open File Limit in Linux</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-832 post type-post status-publish format-standard hentry category-linux-commands category-linux-networking tag-netstat-command-examples tag-sar-command-examples tag-ss-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/check-linux-network-statistics/" rel="bookmark">How to Check Linux Network Statistics from Command Line</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-1194 post type-post status-publish format-standard hentry category-linux-commands tag-locate-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/locate-command-in-linux/" rel="bookmark">How to Install and Use locate Command in Linux</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-179 post type-post status-publish format-standard hentry category-linux-commands category-shell-tips tag-echo-command-examples tag-linux-shell-tips tag-shell-command-tips" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/permanently-set-path-in-linux/" rel="bookmark">How to Permanently Set $PATH in Linux</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-1333 post type-post status-publish format-standard hentry category-linux-commands category-open-source-tools tag-exa-command-examples tag-ls-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/exa-ls-command-alternative/" rel="bookmark">Exa &#8211; A Modern Replacement for ls Command</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-1907 post type-post status-publish format-standard hentry category-linux-commands tag-linux-tips-tricks tag-rsync-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/rsync-progress-when-copying-files/" rel="bookmark">Rsync Show Progress Bar When Copying Files in Linux</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-1891 post type-post status-publish format-standard hentry category-commandline-tools category-linux-commands tag-awk-command-examples tag-commandline-tools tag-grep-command-examples tag-sed-command-examples tag-wc-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/count-number-of-lines-in-file-linux/" rel="bookmark">5 Ways to Count the Number of Lines in a File</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-541 post type-post status-publish format-standard hentry category-linux-commands category-shell-tips tag-cp-command-examples tag-find-command-examples tag-linux-tips-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/copy-files-with-specific-file-extension/" rel="bookmark">How to Copy Files with Specific File Extension Recursively</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-1614 post type-post status-publish format-standard hentry category-linux-commands tag-wget-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
							<h2 class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.linuxshelltips.com/wget-force-ipv4-ipv6-connection/" rel="bookmark">How to Force Wget to Use IPv4 or IPv6 Connection</a></h2>						</header><!-- .entry-header -->
					</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->

	</div><!-- #content -->
</div><!-- #page -->


<div class="site-footer">
			<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container grid-parent">
								<div class="copyright-bar">
					Linux Shell Tips &copy; 2021. All Rights Reserved.
<p>The material in this site cannot be republished either online or offline, without our permission.</p>
<p>Hosting Sponsored by : <a style="font-weight:bold;color:yellow" href="https://www.linode.com/?r=64ebb9f723fed8b32fda84b6594006df08ad24b6" target="_blank" rel="nofollow">Linode Cloud Hosting</a></p>				</div>
			</div>
		</footer><!-- .site-info -->
		</div><!-- .site-footer -->

<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
				<span class="screen-reader-text">Scroll back to top</span>
				
			</a><div class="wplogout-float-social-wrapper hide-on-mobile hide-on-tablet">
	<a class="wplogout-float-social-sharing wplogout-social-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxshelltips.com%2Frestrict-ssh-access-user%2F" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg></a>
	<a class="wplogout-float-social-sharing wplogout-social-twitter" href="https://twitter.com/intent/tweet?text=How+to+Restrict+SSH+Access+to+Certain+Users+in+Linux&amp;url=https%3A%2F%2Fwww.linuxshelltips.com%2Frestrict-ssh-access-user%2F&amp;via=linuxshelltips" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg></a>
	<a class="wplogout-float-social-sharing wplogout-social-linkedin" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.linuxshelltips.com%2Frestrict-ssh-access-user%2F&amp;title=How+to+Restrict+SSH+Access+to+Certain+Users+in+Linux&amp;mini=true" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg></a>
	<a class="wplogout-float-social-sharing wplogout-social-reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxshelltips.com%2Frestrict-ssh-access-user%2F&title=How+to+Restrict+SSH+Access+to+Certain+Users+in+Linux" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M24 11.779c0-1.459-1.192-2.645-2.657-2.645-.715 0-1.363.286-1.84.746-1.81-1.191-4.259-1.949-6.971-2.046l1.483-4.669 4.016.941-.006.058c0 1.193.975 2.163 2.174 2.163 1.198 0 2.172-.97 2.172-2.163s-.975-2.164-2.172-2.164c-.92 0-1.704.574-2.021 1.379l-4.329-1.015c-.189-.046-.381.063-.44.249l-1.654 5.207c-2.838.034-5.409.798-7.3 2.025-.474-.438-1.103-.712-1.799-.712-1.465 0-2.656 1.187-2.656 2.646 0 .97.533 1.811 1.317 2.271-.052.282-.086.567-.086.857 0 3.911 4.808 7.093 10.719 7.093s10.72-3.182 10.72-7.093c0-.274-.029-.544-.075-.81.832-.447 1.405-1.312 1.405-2.318zm-17.224 1.816c0-.868.71-1.575 1.582-1.575.872 0 1.581.707 1.581 1.575s-.709 1.574-1.581 1.574-1.582-.706-1.582-1.574zm9.061 4.669c-.797.793-2.048 1.179-3.824 1.179l-.013-.003-.013.003c-1.777 0-3.028-.386-3.824-1.179-.145-.144-.145-.379 0-.523.145-.145.381-.145.526 0 .65.647 1.729.961 3.298.961l.013.003.013-.003c1.569 0 2.648-.315 3.298-.962.145-.145.381-.144.526 0 .145.145.145.379 0 .524zm-.189-3.095c-.872 0-1.581-.706-1.581-1.574 0-.868.709-1.575 1.581-1.575s1.581.707 1.581 1.575-.709 1.574-1.581 1.574z"/></svg></a>
</div><!--[if lte IE 11]>
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-content/themes/linuxshelltips/js/classList.min.js?ver=2.4.2' id='generate-classlist-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-content/themes/linuxshelltips/js/menu.min.js?ver=2.4.2' id='generate-menu-js'></script>
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-content/themes/linuxshelltips/js/a11y.min.js?ver=2.4.2' id='generate-a11y-js'></script>
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-content/themes/linuxshelltips/js/back-to-top.min.js?ver=2.4.2' id='generate-back-to-top-js'></script>
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linuxshelltips.com/wp-content/plugins/wp-show-posts/js/jquery.matchHeight.js?ver=1.1.3' id='wpsp-matchHeight-js'></script>
<script defer type='text/javascript' src='https://www.linuxshelltips.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.10' id='akismet-form-js'></script>

</body>
</html>
